Technical information

Accepted programming languages:

C++
Java
Python

Operating-system:

Debian/GNU Linux 9.6 (stretch)

Architecure:

x86-64

Desktop enviroment:

xfce4

Compilers/Interpreters:

C++: gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1)
Java: openjdk version “1.8.0_181”
Python: 2.7.13 / 3.5.3

IDE-s/tools:

Codeblocks: 16.01
Eclipse: neoarn.2 (4.6.2)
pycharm: community edition 2018.1.4
Visual Studio Code
Firefox
sublime
gdb
kate


NB! Technical details are not final and might still change!